SDPLocation/occupancyDate is a type of AbsoluteDate in UML but presented in XSD as xs:string (should it be xs:date?)
<xs:simpleType name="AbsoluteDate" sawsdl:modelReference="http://iec.ch/TC57/CIM-generic#AbsoluteDate">
MeterSystemEvents/EndDeviceEvent/Assets has a multiplicity of 1 so should it be named “Asset” instead of “Assets” to follow the naming convention?
Attributes formNumber, kH, and kR do not belong to EndDeviceAsset class in UML but showed up in the XSD. They are native to MeterAsset class.
The following elements are complex data type containing multiplier, unit and value in CIM UML but presented in Part-9 XSDs as simple data type xs:float.